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Overview of formulas & functions
Formulas are equations that perform calculations on values in your worksheet. A
formula starts with an equal sign (=). For example, the following formula
multiplies 2 by 3 and then adds 5 to the result.
=5+2*3

A formula can also contain any or all of the following: functions (function: A
prewritten formula that takes a value or values, performs an operation, and
returns a value or values. Use functions to simplify and shorten formulas on a
worksheet, especially those that perform lengthy or complex calculations.),
references, operators (operator: A sign or symbol that specifies the type of
calculation to perform within an expression. There are mathematical,
comparison, logical, and reference operators.), and constants (constant: A value
that is not calculated and, therefore, does not change. For example, the number
210, and the text "Quarterly Earnings" are constants. An expression, or a value
resulting from an expression, is not a constant.).

Parts of a formula

Functions: The PI() function returns the value of pi: 3.142...
References: A2 returns the value in cell A2.
Constants: Numbers or text values entered directly into a formula, such as 2.
Operators: The ^ (caret) operator raises a number to a power, and the * (asterisk)
operator multiplies.

Notes:
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Formulas
Using a formula can help you analyse data on a
worksheet. With a formula you can perform operations,
such as addition and multiplication. Think of a formula
as one side of an equation whose result is shown in the
cell.

An Excel formula always begins with an
equal sign (=).
Operators

+

Addition

-

Subtraction

/

Division

*

Multiplication

%

Percent

^

Exponentiation

Examples
=B4+B8

=C6*12.5%

=C9/9

=Z42-Z41

=20^2*.15

=(B6*5)+C5

Note: You can use Excel as a calculator if
required. eg. =56*49
Notes:
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Functions
A function is a built-in formula that takes a value or values, performs
an operation and returns a value. The values that you give to a
function are called arguments and are enclosed in parentheses.
For example, instead of typing the formula
=B1+B2+B3
use the SUM function to build the formula
=SUM(B1:B3)
To access the function list choose the Formulas Tab, Function Library.
Help in the Function dialog is especially useful to give a full description
and example of any function.

Some commonly used functions:

= AVERAGE

returns the average of its arguments

= TODAY()

displays current date calculated from
the computer’s clock

= NOW()

displays current time calculated from
the computer’s clock

= MAX ()

returns the maximum value in a list of
arguments

More functions to try
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=CONVERT

converts a number from one
measurement system to another

=SUMIF

adds the cell specified by a given
condition or criteria

=PMT

calculates the payment for a loan
based on constant payments and a
constant interest rate
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Notes:
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Lookup Functions
VLOOKUP Looks in the first column of an array and moves across
the row to return the value of a cell.
Exercise

Under the Lookup & Reference Category select VLOOKUP

Notes:
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Nested functions
In certain cases, you may need to use a function as one of the
arguments (argument: The values that a function uses to perform operations or
calculations. The type of argument a function uses is specific to the function.
Common arguments that are used within functions include numbers, text, cell
references, and names.) of another function. For example, the following formula
uses a nested AVERAGE function and compares the result with the value 50.

The AVERAGE and SUM functions are nested within the IF function.

Valid returns When a nested function is used as an argument, it must return
the same type of value that the argument uses. For example, if the argument
returns a TRUE or FALSE value, then the nested function must return a TRUE or
FALSE. If it doesn't, Microsoft Excel displays a #VALUE! error value.
Nesting level limits A formula can contain up to seven levels of nested
functions. When Function B is used as an argument in Function A, Function B is
a second-level function. For instance, the AVERAGE function and the SUM
function are both second-level functions because they are arguments of the IF
function. A function nested within the AVERAGE function would be a third-level
function, and so on.
I recently discovered INDEX and MATCH - use the INDEX function to find the
value in the intersecting cell where a row and a column meet.
The INDEX function actually uses the result of the MATCH function as its
argument.
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=INDEX(B4:E6,MATCH(A8,A4:A6,0),MATCH(B8,B3:E3,0))
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Goal Seek
Use Goal Seek to find the result you want by adjusting an input value

Exercise using Goal Seek and the PMT function
If you know the result that you want from a formula, but are not sure what
input value the formula needs to get that result, use the Goal Seek feature.
Because you want to calculate the loan interest rate needed to meet your goal,
use the PMT function. The PMT function calculates a monthly payment amount.
In this example, the monthly payment amount is the goal that you seek.
Prepare the worksheet
1. First, add labels in the first column to make it easier to read.
1. In cell A1, type Loan Amount.
2. In cell A2, type Term in Months.
3. In cell A3, type Interest Rate.
4. In cell A4, type Payment.
2. Next, add the values that you know.
1. In cell B1, type 100000. This is the amount that you want to
borrow.
2. In cell B2, type 180. This is the number of months that you want to
pay off the loan.
NOTE Although you know the payment amount that you want, you
do not enter it as a value, because the payment amount is a result of
the formula. Instead, you add the formula to the worksheet and
specify the payment value at a later step, when you use Goal Seek.
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3. Next, add the formula for which you have a goal. For the example, use
the PMT function:


In cell B4, type =PMT(B3/12,B2,B1). This formula calculates the
payment amount. In this example, you want to pay $900 each
month. You don't enter that amount here, because you want to use
Goal Seek to determine the interest rate, and Goal Seek requires
that you start with a formula.
The formula refers to cells B1 and B2, which contain values that you
specified in preceding steps. The formula also refers to cell B3, which
is where you will specify that Goal Seek put the interest rate. The
formula divides the value in B3 by 12 because you specified a
monthly payment, and the PMT function assumes an annual interest
rate.
Because there is no value in cell B3, Excel assumes a 0% interest
rate and, using the values in the example, returns a payment of
$555.56. You can ignore that value for now.

4. Finally, format the target cell (B3) so that it displays the result as a
percentage.


On the Home tab, in the Number group, click Percentage.



Click Increase Decimal or Decrease Decimal to set the
number of decimal places.

Use Goal Seek to determine the interest rate
1. On the Data tab, in the Data Tools group, click What-If Analysis, and
then click Goal Seek.
2. In the Set cell box, enter the reference for the cell that contains the
formula (formula: A sequence of values, cell references, names,
functions, or operators in a cell that together produce a new value. A
formula always begins with an equal sign (=).) that you want to resolve.
In the example, this reference is cell B4.
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3. In the To value box, type the formula result that you want. In the
example, this is -900. Note that this number is negative because it
represents a payment.
4. In the By changing cell box, enter the reference for the cell that
contains the value that you want to adjust. In the example, this reference
is cell B3.
NOTE

The cell that Goal Seek changes must be referenced by the

formula in the cell that you specified in the Set cell box.
5. Click OK.
Goal Seek runs and produces a result, as shown in the following
illustration.

Notes:
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Formula Auditing
Display formulas on a worksheet
You can easily inspect all the formulas on a worksheet at the same time by
switching between a view that shows formulas in their cells and the default view
that shows the values of formulas in their cells. This affects all formulas on the
worksheet.
1. On the Formulas Tab select Show Formulas from the Formula Auditing
group
or
2. Press CTRL + ` (accent) to toggle

Trace Precedents & Dependents
Precedent cells are cells that are referred to by a formula in
another cell. For example, if cell D10 contains the formula =B5,
cell B5 is a precedent to cell D10.
Dependent cells contain formulas that refer to other cells.
For example, if cell D10 contains the formula =B5, cell D10 is a dependent of
cell B5.
To assist you in checking your formulas, you can use the Trace Precedents
and Trace Dependents commands to graphically display, or trace the
relationships between these cells and formulas with tracer arrows (tracer
arrows: Arrows that show the relationship between the active cell and its
related cells. Tracer arrows are blue when pointing from a cell that provides
data to another cell, and red if a cell contains an error value, such as
#DIV/0!.).
Do one of the following.
Trace cells that provide data to a formula (precedents)
1. Select the cell that contains the formula for which you want to find
precedent cells.
2. To display a tracer arrow to each cell that directly provides data to the
active cell, on the Formulas tab, in the Formula Auditing group, click
Trace Precedents
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Blue arrows show cells with no errors. Red arrows show cells that cause
errors. If the selected cell is referenced by a cell on another worksheet or
workbook, a black arrow points from the selected cell to a worksheet icon
.
The other workbook must be open before Excel can trace these
dependencies.
3. To identify the next level of cells that provide data to the active cell,
click Trace Precedents

again.

4. To remove tracer arrows one level at a time, starting with the
precedent cell farthest away from the active cell, on the Formulas
tab, in the Formula Auditing group, click the arrow next to
Remove Arrows, and then click Remove Precedent Arrows
To remove another level of tracer arrows, click the button again.

.

Trace formulas that reference a particular cell (dependents)
1. Select the cell for which you want to identify the dependent cells.
2. To display a tracer arrow (tracer arrows: Arrows that show the
relationship between the active cell and its related cells. Tracer
arrows are blue when pointing from a cell that provides data to
another cell, and red if a cell contains an error value, such as
#DIV/0!.) to each cell that is dependent on the active cell, on the
Formulas tab, in the Formula Auditing group, click Trace Dependents
.
Blue arrows show cells with no errors. Red arrows show cells that
cause errors. If the selected cell is referenced by a cell on another
worksheet or workbook, a black arrow points from the selected cell to
a worksheet icon
. The other workbook must be open before Excel
can trace these dependencies.
1. To identify the next level of cells that depend on the active cell, click
Trace Dependents

again.

2. To remove tracer arrows one level at a time, starting with the
dependent cell farthest away from the active cell, on the Formulas
tab, in the Formula Auditing group, click the arrow next to
Remove Arrows, and then click Remove Dependent Arrows
To remove another level of tracer arrows, click the button again.
Note: If Excel beeps when you click Trace Dependents

.

or Trace

Precedents
, either Excel has traced all levels of the formula, or you
are attempting to trace an item that cannot be traced.
To remove all tracer arrows on the worksheet, on the Formulas tab, in
the Formula Auditing group, click Remove Arrows
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Evaluate a nested formula one step at a time
Sometimes, understanding how a nested formula calculates the final
result is difficult because there are several intermediate calculations
and logical tests. However, by using the Evaluate Formula dialog
box, you can see the different parts of a nested formula evaluated in
the order the formula is calculated. For example, the formula
=IF(AVERAGE(F2:F5)>50,SUM(G2:G5),0) is easier to understand
when you can see the following intermediate results:
Steps shown in the dialog box

Description

=IF(AVERAGE(F2:F5)>50,SUM(G2:G5),0)

The nested formula is initially displayed. The
AVERAGE function and the SUM function are nested
within the IF function.

=IF(40>50,SUM(G2:G5),0)

The cell range F2:F5 contains the values 55, 35, 45,
and 25, and so the result of the AVERAGE(F2:F5)
function is 40.

=IF(False,SUM(G2:G5),0)

Because 40 is not greater than 50, the expression in
the first argument of the IF function (the
logical_test argument) is False.

0

The IF function returns the value of the third
argument (the value_if_false argument). The SUM
function is not evaluated because it is the second
argument to the IF function (value_if_true
argument), and it is returned only when the
expression is True.

1. Select the cell that you want to evaluate. Only one cell can be evaluated
at a time.
2. On the Formulas tab, in the Formula Auditing group, click Evaluate
Formula.

3. Click Evaluate to examine the value of the underlined reference. The
result of the evaluation is shown in italics.
If the underlined part of the formula is a reference to another formula,
click Step In to display the other formula in the Evaluation box. Click
Step Out to go back to the previous cell and formula.
NOTE The Step In button is not available for a reference the second
time the reference appears in the formula, or if the formula refers to a cell
in a separate workbook.
4. Continue until each part of the formula has been evaluated.
5. To see the evaluation again, click Restart.
6. To end the evaluation, click Close.
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Absolute versus Relative References
The difference between absolute, relative and mixed references
Relative references A relative cell reference in a formula, such as A1, is
based on the relative position of the cell that contains the formula and the cell
the reference refers to. If the position of the cell that contains the formula
changes, the reference is changed. If you copy or fill the formula across rows or
down columns, the reference automatically adjusts. By default, new formulas
use relative references. For example, if you copy or fill a relative reference in
cell B2 to cell B3, it automatically adjusts from =A1 to =A2.

Copied formula with relative reference

Absolute references An absolute cell reference in a formula, such as $A$1,
always refer to a cell in a specific location. If the position of the cell that
contains the formula changes, the absolute reference remains the same. If you
copy or fill the formula across rows or down columns, the absolute reference
does not adjust. By default, new formulas use relative references, and you may
need to switch them to absolute references. For example, if you copy or fill an
absolute reference in cell B2 to cell B3, it stays the same in both cells =$A$1.

Copied formula with absolute reference
Mixed references A mixed reference has either an absolute column and
relative row, or absolute row and relative column. An absolute column reference
takes the form $A1, $B1, and so on. An absolute row reference takes the form
A$1, B$1, and so on. If the position of the cell that contains the formula
changes, the relative reference is changed, and the absolute reference does not
change. If you copy or fill the formula across rows or down columns, the relative
reference automatically adjusts, and the absolute reference does not adjust. For
example, if you copy or fill a mixed reference from cell A2 to B3, it adjusts from
=A$1 to =B$1.

Copied formula with mixed reference
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Verify that the cell references in the formula produce the result that you want. If
necessary, switch the type of reference by doing the following:
1. Select the cell that contains the formula.
2. In the formula bar (formula bar: A bar at the top of the Excel
window that you use to enter or edit values or formulas in cells or
charts. Displays the constant value or formula stored in the active
cell.)
, select the reference that you want to change.
3. Press F4 to switch between the combinations.
The following table summarizes how a reference type updates if a formula that
contains the reference is copied two cells down and two cells to the right.

For a formula being copied:

If the reference is:

It changes
to:

$A$1 (absolute column and absolute
row)

$A$1

A$1 (relative column and absolute row)

C$1

$A1 (absolute column and relative row)

$A3

A1 (relative column and relative row)

C3

NOTE: Copy formulas into adjacent cells by using the fill handle (fill handle:
The small black square in the lower-right corner of the selection. When you
point to the fill handle, the pointer changes to a black cross.)
. After
verifying that the cell references in the formula produce the result that you
want, select the cell that contains the copied formula, and then drag the fill
handle over the range that you want to fill.
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Data Validation
To make data entry easier, or to limit entries to certain items that you define,
you can create a drop-down list of valid entries that is compiled from cells
elsewhere in the workbook.
To create a drop-down list from a range of cells, use the Data Validation
command in the Data Tools group on the Data tab.
1. To create a list of valid entries for the drop-down list, type the entries in a
single column or row without blank cells. For example:
A

2.

1

Names

2

Baker

3

Smith

4

Hendrix

NOTE You may want to sort the data in the order that you want it to
appear in the drop-down list.

3. If you want to use another worksheet, type the list on that worksheet,
and then define a name for the list.
How to define a name
1. Select the cell, range of cells that you want to name.
2. Click the Name box at the left end of the formula bar.

3. Type the name for the cells, for example, Fields.
4. Press ENTER.
4. Select the cell where you want the drop-down list.
5. On the Data tab, in the Data Tools group, click Data Validation.

6. In the Data Validation dialog box, click the Settings tab.
7. In the Allow box, click List.
8. To specify the location of the list of valid entries, do one of the following:
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Enter the name that you defined for your list in the Source box.



Make sure that the reference or name is preceded with an equal sign (=).
For example, enter =Fields.
9. Make sure that the In-cell dropdown check box is selected.
10. To specify whether the cell can be left blank, select or clear the Ignore
blank check box.
11. Optionally, display an input message when the cell is clicked.
How to display an input message
1. Click the Input Message tab.
2. Make sure that the Show input message when cell is selected
check box is selected.
3. Type the title and text for the message (up to 225 characters).
12. Specify how you want Microsoft Office Excel to respond when invalid data
is entered.
How to specify a response to invalid data
Click the Error Alert tab, and make sure that the Show error alert
after invalid data is entered check box is selected.
1. Select one of the following options for the Style box:


To display an information message that does not prevent entry
of invalid data, click Information.



To display a warning message that does not prevent entry of
invalid data, click Warning.



To prevent entry of invalid data, click Stop.

2. Type the title and text for the message (up to 225 characters).
NOTE If you don't enter a title or text, the title defaults to
"Microsoft Excel" and the message to: "The value you entered is not
valid. A user has restricted values that can be entered into this cell."
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Sort & Filter
Sort
1. Select a column of alphanumeric data in a range of cells, or make sure
that the active cell is in a table column containing alphanumeric data.
2. On the Data tab, in the Sort & Filter group, do one of the following:


To sort in ascending alphanumeric order, click



To sort in descending alphanumeric order, click

Sort A to Z.
Sort Z to A.

Filter
1. Select a range of cells containing alphanumeric data.
2. On the Data tab, in the Sort & Filter group, click Filter.

2. Click the arrow

in the column header.

3. Do one of the following:
Select from a list of text values


In the list of text values, select or clear one or more text values to
filter by.
Create criteria



Point to Text Filters and then click one of the comparison
operator (comparison operator: A sign that is used in comparison
criteria to compare two values. Operators include: = Equal to, >
Greater than, < Less than, >= Greater than or equal to, <= Less
than or equal to, and <> Not equal to.) commands, or click Custom
Filter.
For example, to filter by text that begins with a specific character,
select Begins With, or to filter by text that has specific characters
anywhere in the text, select Contains.



In the Custom AutoFilter dialog box, in the box on the right, enter
text or select the text value from the list.
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For example, to filter by text that begins with the letter "J", enter J,
or to filter by text that has "bell" anywhere in the text, enter bell.
If you need to find text that shares some characters but not others,
use a wildcard character.
How to use wildcard characters
The following wildcard characters can be used as comparison criteria
for text filters.
Use

To find

? (question mark)

Any single character
For example, sm?th finds "smith" and "smyth"

* (asterisk)

Any number of characters
For example, *east finds "Northeast" and "Southeast"

~ (tilde) followed by ?, *, or ~

A question mark, asterisk, or tilde
For example, fy06~? finds "fy06?"



Optionally, filter by one more criteria.

Filter or Sort by cell color, font color, or icon set
If you have manually or conditionally formatted a range of cells, by cell color or
font color, you can also filter by these colors. You can also filter by an icon set
created through a conditional format.
1. Select a range of cells containing formatted by cell color, font color, or an
icon set.
2. On the Data tab, in the Sort & Filter group, click Filter.

2. Click the arrow

in the column header.

3. Select Filter by Color, and then depending on the type of format, select
Filter by Cell Color, Filter by Font Color, or Filter by Cell Icon.
4. Depending on the type of format, select a color, font color, or cell icon.
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Pivot Tables & Charts
1. Select a cell in a range of cells, or put the insertion point inside of a
Microsoft Office Excel table.
Make sure that the range of cells has column headings.
2. Select the type of report to generate by doing one of the following:


To create a PivotTable report, on the Insert tab, in the Tables
group, click PivotTable, and then click PivotTable.

Excel displays the Create PivotTable dialog box.


To create a PivotTable and PivotChart report, on the Insert tab, in the
Tables group, click PivotTable, and then click PivotChart.
Excel displays the Create PivotTable with PivotChart dialog box.
TIP Consider using a table name reference instead of a range of
cells, because rows added to a table are automatically included in the
PivotTable report when you refresh the data.
NOTE If the range is in another worksheet in the same workbook
or another workbook, type the workbook and worksheet name by
using the following syntax: ([workbookname]sheetname!range).
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Add-ins
1. Select File Options.
2. Click the Add-Ins category.
3. In the Manage box, click Excel Add-ins, and then click Go.
4. To load an Excel add-in, do the following:
1. In the Add-Ins available box, select the check box next to the addin that you want to load, and then click OK.

TIP: If the add-in that you want to use is not listed in the Add-Ins
available box, click Browse, and then locate the add-in. Add-ins
that are not available on your computer can be downloaded from
Downloads on Office Online.
2. If the add-in is not currently installed on your computer, click Yes to
install it. Follow the setup instructions as needed.
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