
 

 

 

  

WORD - ADVANCED 
Extend your editing of simple and 

complex Word documents 

Libby Baker 
libby@msoffice.co.nz 

Abstract 
Skills necessary to work with complex Word documents 



Word Advanced 

© Libby Baker  libby@msoffice.co.nz Page 2 

Contents 

 

Create a Table of Contents ____________________________________________________________ 3 

Mark entries by using heading styles __________________________________________________ 3 

Create a Table of Contents from heading styles _________________________________________ 3 

Format the Table of Contents ________________________________________________________ 3 

Update the Table of Contents _______________________________________________________ 4 

Table of Figures _____________________________________________________________________ 5 

Insert a table of figures _____________________________________________________________ 5 

Update a table of figures ___________________________________________________________ 5 

Review ____________________________________________________________________________ 6 

Track changes _______________________________________________________________________ 6 

Turn off track changes _____________________________________________________________ 6 

Change the way that markup is displayed ______________________________________________ 6 

Customize Toolbars and Ribbon ________________________________________________________ 8 

Quick Access Toolbar ______________________________________________________________ 8 

Add a command to the Quick Access Toolbar ___________________________________________ 8 

Customize Ribbon _________________________________________________________________ 9 

Show the Developer tab ____________________________________________________________ 9 

Master Documents – Outlines _________________________________________________________ 10 

Macros ___________________________________________________________________________ 12 

Record a macro __________________________________________________________________ 12 

Forms and Templates _______________________________________________________________ 15 

Start with a form template _________________________________________________________ 15 

Start with a blank document _______________________________________________________ 15 

Add controls to the form __________________________________________________________ 15 

Content Controls Properties ________________________________________________________ 16 

Add protection to all of the content in a template ______________________________________ 16 

Fields_____________________________________________________________________________ 17 

Edit a field ______________________________________________________________________ 17 

 
  



Word Advanced 

© Libby Baker  libby@msoffice.co.nz Page 3 

Create a Table of Contents 

Mark entries by using heading styles 

1. Select the heading to which you want to apply a heading style.  

2. On the Home tab, in the Styles group, click the style that you want.  

 

For example, if you selected text that you want to style as a main heading, click the style called 
Heading 1 in the Quick Style gallery. 

Create a Table of Contents from heading styles 

1. Click where you want to insert the table of contents, usually at the beginning of a document.  

2. On the References tab, in the Table of Contents group, click Table of Contents, and then click the 
table of contents style that you want.  

 

Format the Table of Contents 

If you already have a table of contents in your document, you can change the options. To do this, you need to 
insert a new table of contents by using the Table of Contents dialog box. 

1. Select the existing table of contents.  

2. On the References tab, in the Table of Contents group, click Table of Contents, and then click Custom 
Table of Contents.  

 

3. In the Table of Contents dialog box, do any of the following:  

 To change how many heading levels are displayed in the table of contents, enter the number 
that you want in the box next to Show levels, under General.  

 To change the overall look of your table of contents, click a different format in the Formats list. 
You can see what your choice looks like in the Print Preview and Web Preview areas.  
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 To change the way heading levels are displayed in the table of contents, click Modify. In the 
Style dialog box, click the level that you want to change, and then click Modify. In the Modify 
Style dialog box, you can change the font, the size, and the amount of indentation. 

Update the Table of Contents 

If you added or removed headings or other table of contents entries in your document, you can quickly update 
the table of contents. 

1. On the References tab, in the Table of Contents group, click Update Table.  

 

2. Click Update entire table.  

 

Note: Right click on the Table of Contents to select Update Field. 
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Table of Figures 

Note: Before you create a table of figures, add captions to all the figures and tables that you want 
included in your table of figures. 

Insert a table of figures 

1. Click in your document where you want to insert the Table of Figures. 

2. Click References > Insert Table of Figures. 

 

3. You can adjust your Format and Options in the Table of Figures dialog box. 

Update a table of figures 

1. Click on the table of figures in your document. This will highlight the entire table. 

2. Click References > Update Table. 

 

3. Select an Update in the in the Update Table of Figures dialog box. Select Update entire table 
if you have moved figures or altered captions. 
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Review 

Track changes 

1. Open the document that you want to revise.  

2. On the Review tab, in the Tracking group, click Track Changes.  

To add a track changes indicator to the status bar, right-click the status bar and click Track 
Changes. Click the Track Changes indicator on the status bar to turn track changes on or off. 

3. Make the changes that you want by inserting, deleting, moving, or formatting text or graphics. 
You can also add comments. 

Turn off track changes 

 On the Review tab, in the Tracking group, click Track Changes.  

 

 NOTE   Turning off change tracking does not eliminate the tracked changes in your document. 

To ensure that there are no more tracked changes in your document, be sure that all changes 
are showing, and then use the Accept or Reject commands for each change in the document. 

Change the way that markup is displayed 

Do any of the following: 

 You can change the color and other formatting that Word uses to mark changed text and 
graphics by clicking the arrow next to Tracking and then select from Track Changes Options 

and Advanced Options. 
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Customize Toolbars and Ribbon 

Quick Access Toolbar 

The Quick Access Toolbar can be located: 

 Upper-left corner next to the File Menu  

 

Click Customize Quick Access Toolbar .  

In the list, click Show Below the Ribbon or Show Above the Ribbon.  

Select More Commands 

Choose commands from All Commands and select Add to Quick Access Toolbar 

Add a command to the Quick Access Toolbar 

You can add a command to the Quick Access Toolbar directly from commands that are displayed on 
the Office Ribbon. 

1. On the Ribbon, click the appropriate tab or group to display the command that you want to add 
to the Quick Access Toolbar.  

2. Right-click the command, and then click Add to Quick Access Toolbar on the shortcut 

menu.  
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Customize Ribbon 

1. Click File > Options > Customize Ribbon 

 

Show the Developer tab 

Use the Developer Tab for Macros, Templates, Protection 

2. Click File > Options. 

3. Click Customize Ribbon. 

4. Under Customize the Ribbon select the Developer check box. 
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Master Documents – Outlines 

 Close Outline View 

On the View tab, in the Document Views group, click the Outline button: 

 

On the Outlining tab appears Master Document buttons: 

 

    Show Document - Toggles the display of all Master 
Document tools except for Show Document and Collapse Subdocuments 

    Collapse Subdocuments - Toggles between showing the 
path and name of the subdocument and showing the subdocument 
content itself 

    Create - Transforms selected outline items into 
subdocuments, each major outline division becomes a separate file 

    Insert - Inserts an independent file into the Master 
Document as a subdocument, use this approach to assemble existing files 
into aMaster Document 

Note: it must be inserted after a heading 

 

    Unlink - Deletes the link to the subdocument and copies the 
subdocument contents into the Master Document. 
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    Merge - Combines multiple subdocuments into one 
subdocument. 

    Split - Splits the selected subdocument into new subdocuments 
at the next lower level of organization. For example, if the subdocument 
has one Heading 1 but multiple Heading 2 styles, then there will be one 
subdocument for each Heading 2 in the selection. 

    Lock Document - Toggles the entire document or 
selected subdocuments to a locked or an unlocked state. Note that this 
provides only cursory protection, however. Any user can unlock the 
subdocument simply by choosing the Lock Document button again. 

There are three main methods of building a Master Document: 

 Combine existing documents into a master document by inserting them as subdocuments. 
Any existing Word document can be treated as a subdocument. 

Starting with an Existing Document 

    1.    Open the document that you want to use as your master document. 

    2.    On the View menu, in the Document Views group, click 
the Outline button. 

    3.    Assign a heading style to each heading (for example, use Heading 
1 for the title and Heading 2 for each subdocument). To do this, use the 
buttons on the Outlining tab: 

 Click Promote  (or Alt+Shift+left arrow) to increase the heading level. 

 Click Demote  (or Alt+Shift+right arrow) to decrease the heading level. 
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Macros  

Record a macro 

1. Click Developer > Record Macro. 

 

2. Type a name for the macro. (one word name only, can include underscores) 

3. To use this macro in any new documents, Store macro in: box says All Documents 
(Normal.dotm). Otherwise select the document name from the dropdown.  

 

  

4. To run your macro when you click a button, click Button. 

 

5. Click the new macro (it’s named something like Normal.NewMacros.<your macro name>), 
and click Add. 
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6. Click Modify. 

 

7. Choose a button image, type the name you want, and click OK twice.  

 

 

8. Now it’s time to record the steps. Click the commands or press the keys for each step in the 
task. Word records your clicks and keystrokes. 
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NOTE:  Use the keyboard to select text while you’re recording your macro. 
Macros don’t record selections made with a mouse. 

9. To stop recording, click Developer >  Stop Recording. 

The button for your macro appears on the Quick Access Toolbar. 

 

To run the macro, click the button. 

1. Click Developer > Macros > Edit. 

Microsoft Visual Basic for Applications opens in a new window. 
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Forms and Templates 

Start with a form template 

1. Click the File tab. 

2. Click New. 

3. Search for Forms in the Templates search box. 

4. Click the form that matches the type you want to create. 

5. Click Download if you're using Word 2010, or Create if you're using Word 2013 or 2016. 

6. Click the File tab again, click Save As and pick a location to save the form. 

7. In the Save As dialog box, type a name for the new template or document, and then 
click Save. 

Start with a blank document 

1. In the form document you've created, click the File tab. 

2. Click Save As. 

3. Under Save as type, select Word template from the menu. 

4. In the Save As dialog box, type a file name for the new template, and then click Save. 

Add controls to the form 

On the Developer tab, in the Controls group, click Design Mode, and then insert the controls that you 
want. 

 

Insert a text control where users can enter text 

In a rich text content control, users can format text as bold or italic, and they can type multiple 
paragraphs. If you want to limit what users add, insert the plain text content control. 

1. Click where you want to insert the control. 

2. On the Developer tab, in the Controls group, click Rich Text Content Control  or Plain 

Text Content Control  . 
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Content Controls Properties 

Each content control has properties that you can set or change.  

1. Click the content control that you want to change. 

2. On the Developer tab, in the Controls group, click Properties, and change the properties that 
you want. 

For example, the Date Picker control offers options for the format you want to use to display 
the date. 

Add protection to all of the content in a template 

1. Open the template that you want to help protect from changes. 

2. Make sure you are not in design mode by clicking Design Mode in the Controls group. 

 

3. On the Developer tab, in the Protect group, click Protect Document, and then click Restrict 
Formatting and Editing. 

 

4. In the Protect Document task pane, under Editing restrictions, select the Allow only this type 
of editing in the document check box. 

5. In the list of editing restrictions, select the restrictions that you want. 

6. Under Start enforcement, click Yes, Start Enforcing Protection. 

7. Save your template. 
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Fields 

1. Click Insert > Quick Parts > Field. 

 

2. In the Field names list, select a field name. 

  

3. Under Field properties, select any properties or options you want, and click OK. 

Edit a field 
1. Right-click in the field, and then click Edit Field. 

2. Change the field properties and options. For information about the properties and options 
available for a particular field, see Field codes in Word or search on the field name in Help. 

NOTE: For some fields, you must display the field code to edit the field. To do this, click the field, 
and then press SHIFT+F9. Or, to display all the field codes in the document, press ALT+F9. 

 


