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Linking Worksheets 

You can link a formula in a worksheet to source data 
located in another worksheet so that any 
changes you make to the source data are 
immediately reflected in 
the linked formula.   
 
Linking One Cell 

1. Select a cell in 
the Target 
worksheet. 

2. Type an = sign to start a formula. 

3. Select the cell in the Source worksheet. 

4. Press Enter. 

 
Linking a Range of Cells 

1. From the Source worksheet select the 
range you would like to use. 

2. Choose Edit Copy. 

3. Select the Target worksheet. 

4. Choose Edit Paste Special. 

5. Select Paste Link. 

 
 

Removing Links 

1. Copy the cell(s) containing 
the formula. 

2. Choose Edit Paste 
Special. 

3. Select the Values 
option button. 

 
Note: Another way to link is to use the camera 

tool. See customising toolbars. 

Notes: 
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Circular References 

 
When a formula uses the cell it's in to try and calculate 
an error message comes up.  
 

 
 
After selecting OK a dialog box appears for every 
circular reference. 

 

 
 
Select the drop down and find each reference. The 
Error may mean editing the formula in the Formula Bar 
e.g. =SUM(C6:C13) 
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Formatting Cells 

Use formatting to add emphasis to your data, or to 
make worksheets easier to read and more visually 
appealing.  You can format numbers to have $’s and 
limited decimal places.   
 
Format worksheet cells before or 
after you enter your data.  Apply cell 
formats by choosing the Cells 

command from the Format menu or try 
your right mouse button.  The most 
frequently used formats are also 

available as buttons on the Formatting 
toolbar.  

1. Select the range you would like to format. 

2. Choose Format Cells and pick the tab(s) with the 
formatting you want. 

3. Choose OK. 

Notes: 
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Conditional Formatting 

Highlight cells that meet specific conditions 

1. Select the cells you want to highlight. 

2. On the Format menu, click Conditional Formatting. 

3. Do one of the following:  

To use values in the selected cells as the formatting 
criteria, click Cell Value Is, select the comparison 
phrase, and then type a value in the appropriate box. You 
can enter a constant value or a formula. If you enter a 
formula, you must start it with an equal sign (=).  

To use a formula as the formatting criteria (to evaluate 
data or a condition other than the values in selected 
cells), click Formula Is in the box on the left, and then 
enter the formula in the box on the right. The formula 
must evaluate to a logical value of TRUE or FALSE.  

4. Click Format. 

5. Select the font style, font color, underlining, borders , 

shading, or patterns you want to apply.  

Microsoft Excel applies the selected formats only if the cell 
value meets the condition or if the formula returns a value 
of TRUE.  

6. To add another condition, click Add, and then repeat 
steps 3 through 5.  
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Styles & Templates 

Styles 

A quick way to format an entire worksheet is to use 
the Format Style menu.   
 
 
 

Select Modify and make any changes.  The default for 
the entire sheet will change. 
 
You can also do this by using the Style drop down 
menu.  See 
customising 
toolbars.  
 
Format a cell as you normally would.  Select the style 
you want to redefine eg Normal.  Choose OK. 

 

Notes: 
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Templates 

If you have a set of styles, formulas, layouts that you 
would like to use again save your workbook as a 
template.   
 
Select File Save As and choose Template under File 
Type.  The extension will be .xlt.  In order to use the 

template close the file.  Reopen by selecting the file 
with the .xlt extension.  You may now make any 
changes and save this file as an Excel Workbook.  You 

may reuse the template as many times as you like.   
 

Notes: 
 
 



  Excel Advanced Topics 

© Libby Baker libbybaker@xtra.co.nz Page 9 of 24 

Lookup Functions 

LOOKUP  
The LOOKUP function has two 
syntax forms, vector and array.  
A vector is an array that contains 
only one row or one column.  The 
vector form of LOOKUP looks in a 
vector for a value, moves to the 
corresponding position in a second 
vector, and returns this value.  
Use this form of the LOOKUP 

function when you want to be 
able to specify the range that 
contains the values you want 

to match. The other form of 
LOOKUP automatically looks 
in the first column or row.   
 
Important   The values must 
be placed in ascending order: ...,-2, -1, 0, 1, 2, ..., A-
Z, FALSE, TRUE; otherwise, LOOKUP may not give the 

correct value. 
 
Note: If LOOKUP can't find the lookup_value, it uses 

the largest value in the array that is less than or equal 
to lookup_value.  

 

HLOOKUP and VLOOKUP allow you to index down or 
across, but LOOKUP always selects the last value in 
the row or column. 
HLOOKUP Looks in the top row of an array and 
returns the value of the indicated cell. 
VLOOKUP Looks in the first column of an array and 
moves across the row to return the value of a cell. 
 
Exercise 

 
 
Under the Lookup & Reference Category in the 
Function Wizard select Lookup 
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Select the first option 

 
 

 
 
In the preceding worksheet: 
 
=LOOKUP(4.91,A2:A7,B2:B7) equals "orange" 
=LOOKUP(7.66,A2:A7,B2:B7) equals "violet" 

Notes: 
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Outlining a Worksheet 

Outline your worksheet data to create summary 
reports.  Show or hide as much detail as you like. 

Automatic Outlining 

Automatic outlining relies on formulas. 

1. Select the data you want to outline. 

2. Select Data, Group and Outline 

3. Choose the Auto Outline 

By selecting the button labelled  you can show 
one level revealing the headings and total.  You 
can also hide the rows by selecting the  
button. 

 

Notes: 
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Removing an Outline 

Remove a portion of an outline or an entire outline 

from your worksheet. 

To remove Do this 

A portion of an outline 1. Select the rows or 
columns from which 
you want the data 
removed.  

2. Choose the Group and 
Outline command from 
the Data menu.  

3. Choose the Clear 
Outline Command. 

The entire outline Select the entire outlined 
range.  Follow steps 2 & 3 

above. 

 

Note: To turn the outline symbols off/on without 

clearing the outline use this icon in the Utilities 
category when customising your toolbars.   

Notes: 
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Add-Ins 

Select the Add-ins command from the Tools menu. 
 
 

 

 

 

 

 

 

 

Analysis Toolpak 

This Add-In contains some valuable functions such as 
Convert for converting from one measurement system 

to another eg miles to kilometres. 

Autosave 

Excel does not have an autosave feature by default.  It 
must be installed through the Add-In Manager. 

Notes: 
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Auditing features 

Auditing Toolbar 
 
Open the Auditing Toolbar by selecting View Toolbars 
Auditing or use your right mouse button on any 
toolbar. 
 
 
 

Tracing Precedents &  Dependents 
 

Precedents are cells that are referred to by a formula.  
Dependents are cells containing formulas that refer to 
other cells.   

 

 
 

Try double-clicking on any arrow. 
 

Notes: 
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Adding Comments 

 
You can attach text to a cell containing a value that 
needs explanation, or to a cell containing a complex 
formula that you want to document for future 
reference.  

1. Select the cell to document. 

2. Click the New Comment button.  

3. Type your note and choose Add. 

 

A red triangle at the top right 
corner of the cell will appear 
indicating a note.  If this does 
not appear select Tools, Options, 
View, Comment Indicator. 
 
 

Printing Comments 
 

1. In the Page Setup menu choose the Sheet 

Tab. 

2. Select Comments. 

3. If you want a cell reference attached to 
the Note choose Row and Column 
headings. 

Notes: 
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Macros 

Overview of Recording and 

Running a Macro 

Recording a macro 
The easiest way to learn 
how to use Excel’s Visual 

Basic is to record a macro. 

 
1. From the Tools menu, choose Macro, and then 

choose Record New Macro. 
 

 
 

2. In the Macro Name box, type a name for 
the macro. 

3. In the Description box, type a description 
of the macro. 

4. Select where you will store the macro. If 
you select Personal Macro Workbook it will 
be available for all of your workbooks. 

5. OK  

6. Carry out the actions that you want to 
record. 

7. Click the Stop Macro button.  
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Recording with Relative/Absolute References 
 

Turns relative references on or off. Unless this 
command is turned off, the Macro Recorder uses 
relative, not absolute, references to cells on a 
worksheet. 

Adding to a Recorded Macro 
 
Alt F11 moves you to the Visual Basic Editor. 
 
As well as directly typing you may copy and paste from 
previously written macros. 

 

Running a macro 
 

1. From the Tools menu, choose Macro. 

2. In the Macro Name/Reference box, type or 
select a macro name. 

3. Choose the Run button. 

Notes: 
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Assigning a Macro to the Tools Menu, a Button, or a 
Graphic Object 

� Select Tools Customize, Commands, Macros 
 

 

� Drag the Custom 
Button to a 
toolbar 

� Right click the 
Smiley Face and 
assign the macro 
to the button 

� Right click to 
make any further 
changes 

 

 

 

 

 

 

Notes: 
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Customising Toolbars 

You can display any of the Excel built-in toolbars, and 
you can customise them to include the buttons that 
you use the most.  You can also create entirely new 
custom toolbars. 
 
Click any toolbar with the right mouse button to 
display the toolbar shortcut menu or choose View 
Toolbars. 
 
Creating Custom Toolbars 

 
To create a custom toolbar choose Toolbars from the 
list and type a name in the Toolbar box.  Choose the 

New button. 
 
The Customise Dialog box will appear.  You can then 
drag the button you want onto the new toolbar. 
 

 
 
Right – click the button to further modify. 

 
Customising Existing Toolbars 
 

To add an existing button to a toolbar, choose the 
Customise command from the toolbar shortcut menu.  
Drag the button to the toolbar.  You may also drag any 
button off a toolbar. 
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Editing a macro 

1. From the Tools menu, choose Macro. 

2. In the Macro Name/Reference box, type or 
select the name of the macro you want to 
display. 

3. Choose the Edit button. 

4. Move the insertion point and then type 
new code or delete existing code as 
necessary. 

 
Note: Select any command and press F1 and the 
context sensitive Visual Basic Help will appear.  Using 

the on-line examples you can copy and paste them 
into a module for reference.  

Notes: 
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To create a user-defined function 
 

1. Create a new Visual Basic module.  Choose 
Macro from the Insert menu, and then 
choose Module. (or use your right button 
on the sheet tab and select Insert Module) 

2. In the module, type Function followed by 
your function name. 

3. Type the arguments, enclosed in 
parentheses, separating each argument 
with a comma. 

4. Press ENTER. 

5. Type your Visual Basic code. 

6. Type End Function and then press 
ENTER. 

 

Example (if the Total is GST exclusive) 

 

Function GST(Total) 

GST=Total/8 
End Function 

 
Using the Function Wizard and selecting the User 
Defined Category your custom functions will be listed. 
 

 

Notes: 
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Hiding & Protecting Worksheets 

Hiding Modules 

 
If you have written a macro that you would like to hide 
select Edit Sheet Hide.  When you select a macro to 
edit it is automatically “Unhidden.”   
 

Hiding Worksheets 

 
While writing macros you may choose to hide 
worksheets and the command is slightly different.  

Choose Format Sheet Hide.  You may also Unhide 
sheets and modules from the same menu. 
 

Notes: 
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Protecting Workbooks & Sheets 

Restricting Access 

 
• Preventing workbooks from 

being opened or saved 
• Protecting formulas, objects, 

headings 

• Hiding a Workbook, selected 
sheets, rows, or columns 

• Preventing formulas from appearing in the formula 

bar 
 

Requiring a Password When a Workbook is Opened 

1. Open the workbook. 

2. Choose File Save As. 

3. Choose the Tools GeneralOptions button. 

4. In the Protection Password box, type a 
password. 

5. Choose OK 

6. Retype the password. 

7. Choose OK. 

 

Note: Passwords are case sensitive.  If you forget 
the password , you cannot open the workbook. 

 

For Look but Don’t Touch access 
 

Follow the previous steps but type the password in the 
Write Reservation Box.   Alternatively you can choose 
Read-Only Recommended.  This allows a user to save 

a copy but the original workbook remains unchanged. 
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Removing Passwords 

 

1. Open the workbook. 

2. Choose File Save As and Options. 

3. Press the Delete key to remove 
password(s). 

 
Protecting an area of your Worksheet 

 

You might want to prevent changes to some cells and 
leave other cells unlocked ie. formulas. 

1. Select the cells that you want to allow 
changes or entries to. 

2. Select Format Cells and the Protection 
Tab. 

 

 

1. Clear the Locked check box. 

2. From the Tools menu select Protection, 
Protect Sheet. 

3. A password is optional. 

Note: You can use the Tab key to move between 
unlocked cells on a protected worksheet. 

 


